3rd party app plugin not working

Support forums for the Habitat Automate plugin
Post Reply
cires316
Posts: 18
Joined: Fri Jan 19, 2018 11:33 pm

3rd party app plugin not working

Post by cires316 »

I am sure I'm missing something.

- in the main console I've got all the apps enabled and it shows "affected agents" so I know it's scanning them.
habitat1.png
habitat1.png (51.62 KiB) Viewed 6791 times
- under a client i have workstations turned on but nothing shows up in the managed apps
habitat2.png
habitat2.png (38.39 KiB) Viewed 6791 times
- habitat logs look to be scanning at 1 am or whatever time they run normally it appears
habitat3.png
habitat3.png (105.92 KiB) Viewed 6791 times

User avatar
Cubert
Posts: 1414
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

Re: 3rd party app plugin not working

Post by Cubert »

What speed do you have your scanner set?

Turtle or rabbit?

Put on rabbit for 24 hours or so. This should speed up to process.


Also look in the plugin logs for the following
App Manage automation running in ....
and
App Manage Maintenance Servie starting
And yes that is a typo, so we will fix that in next release...


The next to look for is
Starting Agent Update Checks
and
Updating associated applications on agent ID -
See if you can find any entries like so.. Also look for the App Manager scripts to be scheduled on agents.

Post back your findings

cires316
Posts: 18
Joined: Fri Jan 19, 2018 11:33 pm

Re: 3rd party app plugin not working

Post by cires316 »

I have had it on rabbit for a few days now.

The only thing I see really in any of the habitat logs is the POSH scans and homebrew. There is nothing about App manage automation, app manage maintenance service, agent update checks or associated app on agent ID.

When I look through all the scripts I don't see anything in here for app manage. I wonder if the install didn't take properly?

MarkHodges
Posts: 16
Joined: Tue Jun 04, 2019 6:07 pm

Re: 3rd party app plugin not working

Post by MarkHodges »

I think I have similar problems, although not all agents are empty, however in mine I noticed that the app_genie plugin log file showed some earlier events saying the license had expired (I used to have app genie trial. I removed both app genie and habitat, then reinstalled habitat, but not sure if that solved the problem with the license).

I still have online machines with no apps and I have it on fast scanning. Could be these machines have zero apps that are in the applications list, but seems fishy...

User avatar
Cubert
Posts: 1414
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

Re: 3rd party app plugin not working

Post by Cubert »

I am adding to the main 3rd Party App Console a new view feature where you are able to select between showing apps effected and agents effected.


Appmanager2.PNG
Appmanager2.PNG (39.21 KiB) Viewed 6335 times

Click either Agents or Apps to change the views from the agents effected by search or Apps effected by search.

User avatar
Cubert
Posts: 1414
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

Re: 3rd party app plugin not working

Post by Cubert »

We just pushed up build 1.0.0.32 today which should really clear up your issues.

Auto updates should handle the plugin update tonight.

cires316
Posts: 18
Joined: Fri Jan 19, 2018 11:33 pm

Re: 3rd party app plugin not working

Post by cires316 »

I can see the managed apps now when I click on the computers so I think that part is working.

Is there not a way to selectively update a single app as opposed to updating all of them for an agent?

User avatar
Cubert
Posts: 1414
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

Re: 3rd party app plugin not working

Post by Cubert »

Not before you asked for it, but with our next release 1.0.0.35 its now in there.

In next build you can select app and right click it to update just that app right now. A terminal will display the progress in the plugin and then the results of the upgrade command. Double click app will bring up the last command log for upgrades if you want to see the last log status of app updates.

Capture.PNG
Capture.PNG (57.86 KiB) Viewed 3491 times

Post Reply