No emails being sent

Post Reply
ericplowman
Posts: 2
Joined: Mon Feb 22, 2021 7:29 pm

No emails being sent

Post by ericplowman »

I have recently installed this plugin, and the data is populating as expected, however, I'm not seeing these emails sent out. Is there some sort of email configuration that need to be done for this to work?

User avatar
Cubert
Posts: 1898
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

Re: No emails being sent

Post by Cubert »

Have a look at your Automate server logs directory for the "plugin_Expiry**.txt" file which will show what the back end is doing.

Next is at what data you have setup in the plugin configurations for the domain.

Image


Notify users should be on and the email message configured.

In the image above the notifier is set to 15 days. This means on the 15 day before the date of expiration of a users password during the first scan of the day to the domain controller the automate script running will see that notify users is turned on and which users are currently in the expire message window. The script then uses the Automate Script Email function to send that user a email one time. After that expiry does not repeat emails to users until the next window applies.

This is all logged in the script log for the agent running on the domain controller. It should log each email it sent and to what user.

Feel free to post up some logs you collected for us to have a peek at what your environment was doing. I believe the emails come directly from Automate so if Automates email system is not setup correctly to forward mail out to a good mail service then you may be either getting tagged as spam or not being sent at all from Automate.

Have a look at your server configs to confirm email is able to flow through Automate.

ericplowman
Posts: 2
Joined: Mon Feb 22, 2021 7:29 pm

Re: No emails being sent

Post by ericplowman »

Ok, after I read what you posted a few times, I had a big oh moment. So, to make sure I understand clearly, if I have users that have passwords that expire in 4 days, and I set it to 5, those users wouldn't get an alert until the next time they reach 5 days? I assumed setting this past the current expiration period would still send the email. I changed this, and it looks like the emails are coming through now.

User avatar
Cubert
Posts: 1898
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

Re: No emails being sent

Post by Cubert »

Correct,

viewtopic.php?f=32&t=5665&sid=4ebdba882 ... 594a873ab2

This post describes why we are doing what we are doing. We use to send mails every scan until the user expired or updated password but got a lot of blowback from community about spamming the user. So we changed it so it would send just one email and stop.

Post Reply

Return to “Expiry Domain Password Expiration Plugin”