CIM Data not showing up for a ESX Host

This forum supports the ESX Host Health Monitor plugin. When posting post screenshots of issues and any script and command logs listed in the probe consoles.
Post Reply
User avatar
Cubert
Posts: 1522
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

CIM Data not showing up for a ESX Host

Post by Cubert »

If the vender type set for that ESX Host system is set to "Auto" then this may apply to you. There was a bug in builds before 4.0.0.32 where systems using "Auto" as a vender whould not display the CIM data. The data was collected but is not matching the query due to this bug. Following the instructions in build 4.0.0.32 should resolve this particular issue but for reference here it is.

We updated the CIM Types table changing Predictive failures to a warning state to match main alarm state. We also updated the table to resolve the auto issues.

You should upgrade to the latest build 4.0.0.36 or newer, then drop the plugin_p4l_vmware_healthmon_types table, restart the DBagent on LT server to recreate table to get new table values.

To drop the table, log into your LT server and open the SQLYog console. Copy the following command and execute it in SQLYog.

Code: Select all

DROP TABLE plugin_p4l_vmware_healthmon_types;
Afterwards restart the LT DBAgent service on the LT server and the table will be recreated correctly. Go back and view your CIM data which should now populate correctly for the "Auto" vender type.

The alternate work around to the above is to change the ESX host vender from auto to unknown which is the same setting basically. This will then show the CIM data as expected.

Post Reply