VMWare ESXi 6.5 has no data after probe

This forum supports the ESX Host Health Monitor plugin. When posting post screenshots of issues and any script and command logs listed in the probe consoles.
Post Reply
User avatar
Cubert
Posts: 1518
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

VMWare ESXi 6.5 has no data after probe

Post by Cubert »

VMware has sent out 6.5 with the watchdog service disable and not really working well from the web UI.

After playing with a fresh install of ESXi 6.5 we found that the CIM services were off and when we turned them on it shows it was running but on further evaluation we found the service had failed and CIM watchdog service was not running.

Going to the SSH console and running a

Code: Select all

/etc/init.d/sfcbd-watchdog start
Produced an error that the watchdog services were administratively disabled.

After doing some research we found that in 6.5 you should enable the service like so

Code: Select all

 esxcli system wbem set --enable true
Afterwards run the following to restart the services

Code: Select all

 /etc/init.d/sfcbd-watchdog start
Next, to verify that the CIM service are running correctly run

Code: Select all

lsof -nPV | awk {'count[$2]++}END{for(i in count)print count[i], i'} | sort -n

Look at the output and see if in the list returned you see the following 2 services

Code: Select all

sfcb-HTTP-Daemo
sfcb-HTTPS-Daem
If they are there then you should be good to go. You can telnet the esxi host on port 5989 and if you do not get a connection rejected message then the ports are open and ready to take cim requests.

Do not just try and start the service, it will say it's running but will have failed to start.
ESX6.5-Web-after-reboot.PNG
ESX6.5-Web-after-reboot.PNG (131.98 KiB) Viewed 5283 times
To see if CIM is running or not just go to the hardware tab in the ESX Web UI. No Data means no CIM services available.
ESX6.5-Web-no-data.PNG
ESX6.5-Web-no-data.PNG (88.4 KiB) Viewed 5283 times

A good output when running watchdog start command

Code: Select all

 /etc/init.d/sfcbd-watchdog start
sfcbd-init: Getting Exclusive access, please wait...
sfcbd-init: Exclusive access granted.
sfcbd-init: Request to start sfcbd-watchdog, pid 69438
sfcbd-config[69448]: No third party cim providers installed
sfcbd-init: snmp has not been enabled.
sfcbd-init: starting sfcbd
sfcbd-init: Waiting for sfcb to start up.
sfcbd-init: Program started normally.

User avatar
Cubert
Posts: 1518
Joined: Tue Dec 29, 2015 7:57 pm
Contact:

Re: VMWare ESXi 6.5 has no data after probe

Post by Cubert »

See how we found this issue at http://www.squidworks.net/2017/02/vmwar ... y-default/

Knowledge is power! :ugeek:

Post Reply